568508097aadcaa44e0e069d45a28aa9ca9e825d
[libradsec.git] / packaging / rpm / radsecproxy.spec
1 Summary: radsecproxy is a generic RADIUS proxy that provides both RADIUS UDP and TCP/TLS (RadSec) transport.
2 Name: radsecproxy
3 Version: 1.0.alpha
4 Release: 1
5 Group: Applications/Communications
6 License: BSD
7 URL: http://software.uninett.no/radsecproxy
8 Packager: Arnes <aaa-podpora@arnes.si>
9 Source: http://software.uninett.no/radsecproxy/radsecproxy-1.0-alpha.tar.gz
10 Source1: radsecproxy.sysv
11 Source2: radsecproxy.1
12 Source3: radsecproxy.conf.5
13 Requires: openssl >= 0.9.7a
14
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16 BuildRequires: openssl-devel >= 0.9.7a
17
18 %description
19 radsecproxy is a generic RADIUS proxy that in addition to to
20 usual RADIUS UDP transport, also supports TLS (RadSec). The
21 aim is for the proxy to have sufficient features to be flexible,
22 while at the same time to be small, efficient and easy to configure.
23 Currently the executable on Linux is only about 48 Kb, and it uses
24 about 64 Kb (depending on the number of peers) while running.
25
26 The proxy was initially made to be able to deploy RadSec (RADIUS
27 over TLS) so that all RADIUS communication across network links
28 could be done using TLS, without modifying existing RADIUS software.
29 This can be done by running this proxy on the same host as an existing
30 RADIUS server or client, and configure the existing client/server to
31 talk to localhost (the proxy) rather than other clients and servers
32 directly.
33
34 There may however be other situations where a RADIUS proxy might be
35 useful. Some people deploy RADIUS topologies where they want to
36 route RADIUS messages to the right server. The nodes that do purely
37 routing could be using a proxy. Some people may also wish to deploy
38 a proxy on a firewall boundary. Since the proxy supports both IPv4
39 and IPv6, it could also be used to allow communication in cases
40 where some RADIUS nodes use only IPv4 and some only IPv6.
41
42 %prep
43 %setup -n %{name}-1.0-alpha
44
45 %build
46 %{__make}
47
48 %install
49 %{__rm} -rf %{buildroot}
50 %{__install} -D -m0644 radsecproxy.conf-example %{buildroot}%{_docdir}/%{name}-%{version}/radsecproxy.conf-example
51 %{__install} -D -m0644 AUTHORS                  %{buildroot}%{_docdir}/%{name}-%{version}/AUTHORS
52 %{__install} -D -m0644 ChangeLog                %{buildroot}%{_docdir}/%{name}-%{version}/ChangeLog
53 %{__install} -D -m0644 COPYING                  %{buildroot}%{_docdir}/%{name}-%{version}/COPYING
54 %{__install} -D -m0644 README                   %{buildroot}%{_docdir}/%{name}-%{version}/README
55 %{__install} -D -m0755 radsecproxy              %{buildroot}%{_sbindir}/radsecproxy
56 %{__install} -D -m0755 %{SOURCE1}               %{buildroot}%{_initrddir}/radsecproxy
57 %{__install} -D -m0644 %{SOURCE2}               %{buildroot}%{_mandir}/man1/radsecproxy.1
58 %{__install} -D -m0644 %{SOURCE3}               %{buildroot}%{_mandir}/man5/radsecproxy.conf.5
59
60 %clean
61 %{__rm} -rf %{buildroot}
62
63 %post
64 /sbin/chkconfig --add radsecproxy
65
66 %preun
67 if [ $1 -eq 0 ]; then
68         /sbin/service radsecproxy stop &>/dev/null || :
69         /sbin/chkconfig --del radsecproxy
70 fi
71
72 %postun
73 if [ $1 -ge 1 ]; then
74         /sbin/service radsecproxy condrestart &> /dev/null || :
75 fi
76
77 %files
78 %defattr(-, root, root, 0755)
79 %config %{_initrddir}/radsecproxy
80 %{_sbindir}/radsecproxy
81 %doc %{_docdir}/%{name}-%{version}/AUTHORS
82 %doc %{_docdir}/%{name}-%{version}/ChangeLog
83 %doc %{_docdir}/%{name}-%{version}/COPYING
84 %doc %{_docdir}/%{name}-%{version}/README
85 %doc %{_docdir}/%{name}-%{version}/radsecproxy.conf-example
86 %doc %{_mandir}/man1/radsecproxy.1.gz
87 %doc %{_mandir}/man5/radsecproxy.conf.5.gz
88
89 %changelog
90 * Thu Jun 07 2007 Rok Papez <aaa-podpora@arnes.si> - 1.0-alpha.1
91 - Initial packaging of the 1.0-alpha.1 release 
92 - Added SysV/RedHat init script
93 - Added radsecproxy manages