Added files from 'suse', to shorten the chain of patches.
[freeradius.git] / suse / freeradius.spec
1 #
2 # spec file for package freeradius (Version 0.4)
3 #
4 # Copyright (c) 2002 SuSE Linux AG, Nuernberg, Germany.
5 # This file and all modifications and additions to the pristine
6 # package are under the same license as the package itself.
7 #
8 # please send bugfixes or comments to feedback@suse.de.
9 #
10
11 # neededforbuild  cyrus-sasl-devel heimdal-devel heimdal-lib mysql-devel mysql-shared openldap2 openldap2-client openldap2-devel openssl openssl-devel postgresql-devel postgresql-libs
12 # usedforbuild    aaa_base aaa_dir aaa_version autoconf automake base bash bindutil binutils bison bzip cpio cpp cracklib cyrus-sasl cyrus-sasl-devel db devs diffutils e2fsprogs file fileutils findutils flex gawk gcc gdbm gdbm-devel gettext glibc glibc-devel glibc-locale gpm gppshare grep groff gzip heimdal-devel heimdal-lib kbd less libtool libz m4 make man mktemp modutils mysql-devel mysql-shared ncurses ncurses-devel net-tools netcfg openldap2 openldap2-client openldap2-devel openssl openssl-devel pam pam-devel pam-modules patch perl postgresql-devel postgresql-libs ps rcs readline rpm sendmail sh-utils shadow strace syslogd sysvinit texinfo textutils timezone unzip util-linux vim
13
14 Name:         freeradius
15 Copyright:    GPL
16 Group:        Productivity/Networking/Radius/Servers
17 Provides:     radiusd
18 Conflicts:    radiusd-livingston radiusd-cistron icradius
19 Version:      0.4
20 Release:      129
21 URL:          http://www.freeradius.org/
22 Summary:      Very high configurable Radius-server (BETA)
23 Source0:      %{name}-%{version}.tar.bz2
24 Source1:      rcradiusd
25 Source2:      radiusd-pam
26 Patch:        heimdal.dif
27 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
28         
29
30 %description
31 The FreeRADIUS server has a number of features which are found in other
32 servers, and additional features which are not found in any other server.
33 Rather than doing a feature by feature comparison, we will simply list
34 the features of the server, and let you decide if they satisfy your needs.
35
36 Support for RFC and VSA Attributes
37 Additional server configuration attributes
38 Selecting a particular configuration
39 Authentication methods
40 Accounting methods
41
42 Authors:
43 --------
44     Miquel van Smoorenburg <miquels@cistron.nl>
45     Alan DeKok <aland@ox.org>
46     Mike Machado <mike@innercite.com>
47     Alan Curry
48     various other people
49
50 SuSE series: n
51
52 %package devel
53 Group:        Development/Libraries/C and C++
54 Summary:      FreeRADIUS development files (static libs)
55
56 %description devel
57 These are the static libraries of the FreeRADIUS package
58
59 Authors:
60 --------
61     Miquel van Smoorenburg <miquels@cistron.nl>
62     Alan DeKok <aland@ox.org>
63     Mike Machado <mike@innercite.com>
64     Alan Curry
65     various other people
66
67 SuSE series: n
68
69 %prep
70 %setup -n radiusd
71 %patch
72 %{?suse_update_config:%{suse_update_config}}
73
74 %build
75 CFLAGS="$RPM_OPT_FLAGS" ./configure \
76                 --prefix=/ \
77                 --exec_prefix=/usr \
78                 --sysconfdir=%{_sysconfdir} \
79                 --infodir=%{_infodir} \
80                 --mandir=%{_mandir} \
81                 --with-rlm-krb5-include-dir=/usr/include/heimdal/ \
82                 --with-rlm-krb5-lib-dir=/usr/lib/
83 make
84
85 %install
86 [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf \
87 $RPM_BUILD_ROOT
88 mkdir -p $RPM_BUILD_ROOT
89 make install R=$RPM_BUILD_ROOT
90 ldconfig -n $RPM_BUILD_ROOT%{prefix}/lib
91 # logs
92 touch $RPM_BUILD_ROOT/var/log/radius/radius.log
93 touch $RPM_BUILD_ROOT/var/log/radius/radwatch.log
94 touch $RPM_BUILD_ROOT/var/log/radius/radwtmp
95 touch $RPM_BUILD_ROOT/var/log/radius/radutmp
96 # SuSE
97 install -d     $RPM_BUILD_ROOT/etc/pam.d
98 install -m 644 %SOURCE2 $RPM_BUILD_ROOT/etc/pam.d/radiusd
99 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
100 install    -m 744 %SOURCE1 $RPM_BUILD_ROOT/etc/init.d/radiusd
101 ln -sf ../../etc/init.d/radiusd $RPM_BUILD_ROOT/usr/sbin/rcradiusd
102
103 %post
104 %{fillup_and_insserv -s radiusd START_RADIUSD }
105
106 %postun
107 %{insserv_cleanup}
108
109 %clean
110 [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT
111
112 %files
113 # doc
114 %doc doc/* LICENSE COPYRIGHT CREDITS README
115 # SuSE
116 %config /etc/init.d/radiusd
117 %config /etc/pam.d/radiusd
118 /usr/sbin/rcradiusd
119 # configs
120 %dir /etc/raddb
121 %config(noreplace) /etc/raddb/acct_users
122 %config(noreplace) /etc/raddb/attrs
123 %config(noreplace) /etc/raddb/clients
124 %config(noreplace) /etc/raddb/clients.conf
125 %config /etc/raddb/dictionary
126 %config /etc/raddb/dictionary.acc
127 %config /etc/raddb/dictionary.ascend
128 %config /etc/raddb/dictionary.bay
129 %config /etc/raddb/dictionary.cisco
130 %config /etc/raddb/dictionary.compat
131 %config /etc/raddb/dictionary.erx
132 %config /etc/raddb/dictionary.freeradius
133 %config /etc/raddb/dictionary.livingston
134 %config /etc/raddb/dictionary.microsoft
135 %config /etc/raddb/dictionary.nomadix
136 %config /etc/raddb/dictionary.redback
137 %config /etc/raddb/dictionary.shasta
138 %config /etc/raddb/dictionary.shiva
139 %config /etc/raddb/dictionary.tunnel
140 %config /etc/raddb/dictionary.usr
141 %config /etc/raddb/dictionary.versanet
142 %config(noreplace) /etc/raddb/hints
143 %config(noreplace) /etc/raddb/huntgroups
144 %config(noreplace) /etc/raddb/ldap.attrmap
145 %config(noreplace) /etc/raddb/naslist
146 %config(noreplace) /etc/raddb/naspasswd
147 %config(noreplace) /etc/raddb/proxy.conf
148 %config(noreplace) /etc/raddb/radiusd.conf
149 %config(noreplace) /etc/raddb/realms
150 %config(noreplace) /etc/raddb/snmp.conf
151 %config(noreplace) /etc/raddb/sql.conf
152 %config(noreplace) /etc/raddb/users
153 %config(noreplace) /etc/raddb/x99.conf
154 %config(noreplace) /etc/raddb/x99passwd.sample
155 # binaries
156 /usr/bin/*
157 /usr/sbin/check-radiusd-config
158 /usr/sbin/checkrad
159 /usr/sbin/radiusd
160 /usr/sbin/radwatch
161 # shared libs
162 /usr/lib/*.so.*
163 /usr/lib/*.la
164 # man-pages
165 %doc %{_mandir}/man1/*
166 %doc %{_mandir}/man5/*
167 %doc %{_mandir}/man8/*
168 # logs
169 %dir /var/log/radius/
170 %dir /var/log/radius/radacct/
171 /var/log/radius/radutmp
172 %ghost /var/log/radius/radwtmp
173 %ghost /var/log/radius/radius.log
174 %ghost /var/log/radius/radwatch.log
175
176 %files devel
177 /usr/lib/*.a
178 /usr/lib/*.so
179
180 %changelog -n freeradius
181 * Mon Feb 25 2002 - stark@suse.de
182 - moved *.la back to main-package as it is needed for
183   dynamic loading of modules
184 * Mon Feb 25 2002 - stark@suse.de
185 - added patch to work with heimdal-krb5
186 - moved *.so to -devel package
187 * Fri Feb 08 2002 - stark@suse.de
188 - deactivated kerberos support
189   (seems to be not compatible with heimdal :-()
190 * Thu Feb 07 2002 - stark@suse.de
191 - changed heimdal libdir
192 * Thu Dec 13 2001 - stark@suse.de
193 - update to 0.4
194 - better use of fillup_and_insserv
195 * Mon Dec 03 2001 - stark@suse.de
196 - don't use START_RADIUSD anymore
197 - make use of new fillup_and_insserv macro
198 * Fri Oct 12 2001 - stark@suse.de
199 - update to version 0.3
200 - packed source-archive as bz2
201 - branched package -> devel
202 * Fri Aug 03 2001 - stark@suse.de
203 - removed use of watcher-script
204 - removed config-check (-C) in init script
205   (it's not supported in freeradius)
206 * Thu Aug 02 2001 - stark@suse.de
207 - status fix in init script
208 - renamed pam-configfile: radius -> radiusd
209 * Wed Aug 01 2001 - stark@suse.de
210 - updated to 0.2
211 * Thu Jul 26 2001 - kukuk@suse.de
212 - Fix needed for build
213 * Tue Jul 10 2001 - stark@suse.de
214 - added %%{suse_update_config}
215 * Sat Jun 23 2001 - schwab@suse.de
216 - Fix preprocessor directives inside macro arguments.
217 * Mon Jun 18 2001 - stark@suse.de
218 - removed absolute paths from pam-config
219 * Wed May 23 2001 - stark@suse.de
220 - first official beta-version 0.1
221 * Wed Mar 21 2001 - stark@suse.de
222 - new snapshot 20010321 (pre-BETA)
223 - replaced start- and killproc to avoid problems with Kernel 2.4
224   using the radwatch shell-script
225 - added built of LDAP and MySQL modules
226 * Mon Jan 29 2001 - stark@suse.de
227 - %%files: /etc/raddb/bay.vendor -> /etc/raddb/dictionary.bay
228 * Mon Jan 15 2001 - stark@suse.de
229 - new snapshot 20010115
230 - initial BETA package (sources are ALPHA!)
231 * Thu Jan 04 2001 - stark@suse.de
232 - CVS snapshot 20010104