import from HEAD:
[freeradius.git] / redhat / freeradius.spec
index 460f2e3..55de003 100644 (file)
@@ -1,7 +1,7 @@
 Summary: High-performance and highly configurable RADIUS server
 URL: http://www.freeradius.org/
 Name: freeradius
-Version: 0.6
+Version: 1.1.0
 Release: 1
 License: GPL
 Group: Networking/Daemons
@@ -10,6 +10,7 @@ Source0: %{name}-%{version}.tar.gz
 Prereq: /sbin/chkconfig
 BuildPreReq: libtool
 # FIXME: snmpwalk, snmpget and rusers POSSIBLY needed by checkrad
+Provides: radiusd
 Conflicts: cistron-radius
 BuildRoot: %{_tmppath}/%{name}-root
 
@@ -19,7 +20,7 @@ configurable GPL'd RADIUS server. It is somewhat similar to the
 Livingston 2.0 RADIUS server, but has many more features, and is much
 more configurable.
 
-%prep 
+%prep
 %setup
 
 %build
@@ -28,10 +29,12 @@ CFLAGS="$RPM_OPT_FLAGS" \
        --localstatedir=%{_localstatedir} \
        --sysconfdir=%{_sysconfdir} \
        --mandir=%{_mandir} \
-       --with-threads \
-       --with-thread-pool \
-       --with-gnu-ld \
+       --with-system-libtool \
        --disable-ltdl-install \
+       --with-ltdl-lib=/usr/lib \
+       --with-ltdl-include=/usr/include \
+       --with-gnu-ld \
+       --with-large-files --with-udpfromto --with-edir \
        --with-rlm-sql_postgresql-include-dir=/usr/include/pgsql \
        --with-rlm-krb5-include-dir=/usr/kerberos/include \
        --with-rlm-krb5-lib-dir=/usr/kerberos/lib
@@ -44,13 +47,12 @@ mkdir -p $RPM_BUILD_ROOT/etc/{logrotate.d,pam.d,rc.d/init.d}
 
 make install R=$RPM_BUILD_ROOT
 
+RADDB=$RPM_BUILD_ROOT/etc/raddb
 # set radiusd as default user/group
-sed -e 's/^user =.*$/user = radiusd/' -e 's/^group =.*$/group = radiusd/' < $RPM_BUILD_ROOT/etc/raddb/radiusd.conf > $RPM_BUILD_ROOT/radiusd.conf.tmp
-mv $RPM_BUILD_ROOT/radiusd.conf.tmp $RPM_BUILD_ROOT/etc/raddb/radiusd.conf
-
+perl -i -pe 's/^#user =.*$/user = radiusd/' $RADDB/radiusd.conf
+perl -i -pe 's/^#group =.*$/group = radiusd/' $RADDB/radiusd.conf
 # shadow password file MUST be defined on Linux
-sed -e 's/#    shadow =/shadow =/' < $RPM_BUILD_ROOT/etc/raddb/radiusd.conf > $RPM_BUILD_ROOT/radiusd.conf.tmp
-mv $RPM_BUILD_ROOT/radiusd.conf.tmp $RPM_BUILD_ROOT/etc/raddb/radiusd.conf
+perl -i -pe 's/#       shadow =/shadow =/' $RADDB/radiusd.conf
 
 # remove unneeded stuff
 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/builddbm.8
@@ -101,17 +103,32 @@ fi
 %config /etc/pam.d/radius
 %config /etc/logrotate.d/radiusd
 %config /etc/rc.d/init.d/radiusd
-%config (noreplace) /etc/raddb/[a-ce-z]*
-%config /etc/raddb/d*
+%config (noreplace) /etc/raddb/*
+%{_bindir}/*
+%{_datadir}/%{name}
+%{_libdir}/*
 %{_mandir}/*/*
-/usr/bin/*
-/usr/sbin/*
-/usr/lib/*
+%{_sbindir}/*
 %attr(0700,radiusd,radiusd) %dir /var/log/radius
 %attr(0700,radiusd,radiusd) %dir /var/log/radius/radacct
 %attr(0700,radiusd,radiusd) %dir /var/run/radiusd
 
 %changelog
+* Thurs Dec 15 2004 Alan DeKok
+- update for 1.1.0
+
+* Mon May 31 2004 Paul Hampson
+- update for 1.0.0 release
+
+* Fri May 23 2003 Marko Myllynen
+- update for 0.9
+
+* Wed Sep  4 2002 Marko Myllynen
+- fix libtool issues for good
+
+* Thu Aug 22 2002 Marko Myllynen
+- update for 0.7/0.8
+
 * Tue Jun 18 2002 Marko Myllynen
 - run as radiusd user instead of root
 - added some options for configure