Centos and Debian packaging
[devwiki.git] / release / debian.mdwn
diff --git a/release/debian.mdwn b/release/debian.mdwn
new file mode 100644 (file)
index 0000000..d7d2b06
--- /dev/null
@@ -0,0 +1,63 @@
+[[!meta title="Debian Packaging"]]
+
+Debian packages use the debian branch of the master repository.
+
+# Selecting the right branch
+
+In the master repository:
+
+    git checkout debian
+    git submodule update --init
+
+# Per package Instructions
+
+In each package you wish to update:
+
+## Select Debian Branch
+
+Change directories into the package and run:
+
+    git checkout debian
+
+## Updating Package with New Code
+
+Merge in the source code changes.  To merge in master:
+
+    git pull origin master
+
+Now run:
+    dch -i
+
+This brings up a changelog where you can describe the changes in this
+version.  Check the version number on the first line.  If the upstream
+has changed then update the version number to be
+upstream_version_number-1.  Otherwise if the upstream has not changed, then a new debian revision should have been created.
+Describe the changes in the space provided.  Make sure that the "distribution" on the first line is "unstable" not "UNRELEASED".
+
+    git add debian/changelog
+    git commit
+
+Push the debian branch:
+
+    git push origin debian
+
+## Update Master Repository
+
+"git add" each updated package to the bmaster repository and then commit.  Push the debian branch of the master repository.  This will trigger builds for 64-bit and 32-bit.  Check the status [here](http://www.project-moonshot.org/buildbot/builders/).  Once the builds succeed, the packages will be in the wheezy-proposed area of our archive.
+
+# Wheezy and Wheezy-proposed
+
+We maintain two areas of our Debian archive described by the following /etc/apt/sources.list lines:
+
+    deb http://repository.project-moonshot.org/debian-moonshot wheezy main 
+    deb http://repository.project-moonshot.org/debian-moonshot wheezy-proposed main
+
+The wheezy-proposed  archive should be used to grab the latest software, and the wheezy archive should be used for known good software.  When Live DVD images are produced, they install the software from wheezy-proposed.  However, the resulting image will only upgrade software from wheezy.  The intent is that you probably want to test the latest software when building a new DVD image, but until it is known to work, others may not want to upgrade to it.  To copy all software from wheezy-proposed to wheezy:
+
+    ssh buildbot@moonshot.suchdamage.org
+    cd /srv/debian
+    reprepro pull wheezy
+
+The "reprepro copy" command can be used to move individual packages.
+
+