update libtool to 1.4.2
[freeradius.git] / libltdl / Makefile.am
index 87b48bb..c0b6c0b 100644 (file)
@@ -2,8 +2,6 @@
 
 AUTOMAKE_OPTIONS = no-dependencies foreign
 
-DESTDIR = $(R)
-
 if INSTALL_LTDL
 include_HEADERS = ltdl.h
 lib_LTLIBRARIES = libltdl.la
@@ -15,8 +13,12 @@ if CONVENIENCE_LTDL
 noinst_LTLIBRARIES = libltdlc.la
 endif
 
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libltdl.la libltdlc.la
+
 libltdl_la_SOURCES = ltdl.c
-libltdl_la_LDFLAGS = -version-info 1:2:1
+libltdl_la_LDFLAGS = -no-undefined -version-info 4:0:1
 libltdl_la_LIBADD = $(LIBADD_DL)
 
 libltdlc_la_SOURCES = ltdl.c