Merge pull request #1592 from spbnick/dlopen_actual_libpython
[freeradius.git] / src / modules / rlm_python / configure.ac
index 831a33a..00589f9 100644 (file)
@@ -126,6 +126,8 @@ if test x$with_[]modname != xno; then
                        fi
                fi
        fi
+
+       AC_CHECK_FUNCS([dl_iterate_phdr])
 else
        targetname=
        echo \*\*\* module modname is disabled.
@@ -141,6 +143,7 @@ if test x"$fail" != x""; then
        fi
 fi
 
+AC_CONFIG_HEADER(config.h)
 AC_SUBST(mod_ldflags)
 AC_SUBST(mod_cflags)
 AC_SUBST(targetname)