Final fixes for getting GSSWeb to work again.
[gssweb.git] / gssweb.spec
1 %global _firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
2
3 # common macros, yet to be defined. see:
4 # https://fedoraproject.org/wiki/User:Kalev/MozillaExtensionsDraft
5 %global _moz_extensions %{_datadir}/mozilla/extensions
6 %global _firefox_extdir %{_moz_extensions}/%{_firefox_app_id}
7
8 # needed for this package
9 %global extension_id gssweb@painless-security.com
10 %global _our_extdir %{_firefox_extdir}/%{extension_id}
11 Name:           gssweb
12 Version:        0.1
13 Release:        1%{?dist}
14 Summary:        GSS-API for Javascript and the Web
15
16 Group:          Security Tools
17 License:        BSD
18 URL:            http://www.project-moonshot.org/
19 Source0:        gssweb-%{version}.tar.gz
20 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 BuildRequires:   openssl-devel, cppunit-devel, jansson-devel, krb5-devel, glib-devel
23 BuildRequires:  unzip
24 Requires:       moonshot-ui
25
26
27
28 %description
29 This includes the json GSSAPI executables and libraries.
30
31 %package -n firefox-gssweb
32 Summary: Firefox Support for GssWeb
33 Requires: mozilla-filesystem, gssweb
34
35 %description -n firefox-gssweb
36 An extension to support gssweb for Firefox web browser.
37
38
39 %prep
40 %setup -q -n gssweb
41
42
43 %build
44 %cmake
45 make %{?_smp_mflags}
46
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 make install DESTDIR=$RPM_BUILD_ROOT
51      install -d $RPM_BUILD_ROOT/%{_our_extdir}
52 xpi=`pwd`/browsers/firefox/gssweb.xpi&&(cd $RPM_BUILD_ROOT/%{_our_extdir}&&unzip $xpi)
53
54
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59
60 %files
61 %defattr(-,root,root,-)
62 %{_libdir}/libjsongssapi.so
63  %{_libdir}/libjsongssapi.so.*
64 %{_bindir}/json_gssapi
65 %files -n firefox-gssweb
66 %defattr(-,root,root,-)
67 %{_our_extdir}
68
69
70
71 %changelog
72