disable unit tests on windows
[gssweb.git] / json_gssapi / test / CMakeLists.txt
index d883110..ab09be3 100644 (file)
@@ -7,7 +7,8 @@ if (GLIB2_FOUND)
   include_directories(${GLIB2_INCLUDE_DIRS})
 endif(GLIB2_FOUND)
   
-
+if (WIN32)
+else (WIN32)
 add_executable(test GSSExceptionTest.cpp 
                     GSSAcquireCredTest.cpp 
                     GSSGetMicTest.cpp
@@ -25,8 +26,10 @@ add_executable(test GSSExceptionTest.cpp
                     GSSImportNameTest.cpp
                     command_mocks/MockImportName.cpp
                     test_run.cpp 
-                    ../src/commands/GSSCreateSecContextCommand.cpp 
+                    ../src/commands/GSSInitSecContext.cpp 
+                    ../src/util_base64.cpp
                     ../src/util_json.cpp 
+                    ../src/util_random.cpp
                     ../src/commands/GSSImportName.cpp
                     ../src/GSSException.cpp
                     ../src/commands/GSSGetMic.cpp
@@ -36,11 +39,11 @@ add_executable(test GSSExceptionTest.cpp
                     ../src/commands/GSSWrap.cpp
                     ../src/datamodel/GSSBuffer.cpp
                     ../src/datamodel/GSSCredential.cpp
+                    ../src/datamodel/GSSDisplayStatus.cpp
                     ../src/datamodel/GSSName.cpp
                     ../src/datamodel/GSSOID.cpp
                     ../src/datamodel/GSSOIDSet.cpp
                     ../src/datamodel/GSSContext.cpp
-                    ../src/util/base64.cpp
                     ../src/cache/GSSContextCache.cpp
                     ../src/cache/GSSNameCache.cpp
                     datamodel/GSSBufferTest.cpp
@@ -48,8 +51,8 @@ add_executable(test GSSExceptionTest.cpp
   )
 
 target_link_libraries(test cppunit gssapi_krb5 jansson crypto ${GLIB2_LIBRARIES})
-
 # install(TARGETS test RUNTIME DESTINATION bin)
+endif(WIN32)
 
 add_subdirectory(datamodel)
-add_subdirectory(command_mocks)
\ No newline at end of file
+add_subdirectory(command_mocks)