add util_base64 and util_random
[gssweb.git] / json_gssapi / test / CMakeLists.txt
index 7f160c9..f4c2ff0 100644 (file)
@@ -26,7 +26,9 @@ add_executable(test GSSExceptionTest.cpp
                     command_mocks/MockImportName.cpp
                     test_run.cpp 
                     ../src/commands/GSSInitSecContext.cpp 
+                    ../src/util_base64.cpp
                     ../src/util_json.cpp 
+                    ../src/util_random.cpp
                     ../src/commands/GSSImportName.cpp
                     ../src/GSSException.cpp
                     ../src/commands/GSSGetMic.cpp
@@ -52,4 +54,4 @@ target_link_libraries(test cppunit gssapi_krb5 jansson crypto ${GLIB2_LIBRARIES}
 # install(TARGETS test RUNTIME DESTINATION bin)
 
 add_subdirectory(datamodel)
-add_subdirectory(command_mocks)
\ No newline at end of file
+add_subdirectory(command_mocks)