Run Sphinx without the -W flag when building documentation
[jansson.git] / doc / Makefile.am
index 1a3f560..1f2d855 100644 (file)
@@ -1,8 +1,9 @@
-EXTRA_DIST = conf.py apiref.rst changes.rst gettingstarted.rst         \
-       github_commits.c index.rst tutorial.rst ext/refcounting.py
+EXTRA_DIST = conf.py apiref.rst changes.rst conformance.rst            \
+       gettingstarted.rst github_commits.c index.rst tutorial.rst      \
+       ext/refcounting.py
 
 SPHINXBUILD = sphinx-build
-SPHINXOPTS = -d _build/doctrees -W
+SPHINXOPTS = -d _build/doctrees $(SPHINXOPTS_EXTRA)
 
 html-local:
        $(SPHINXBUILD) -b html $(SPHINXOPTS) $(srcdir) _build/html
@@ -16,4 +17,4 @@ uninstall-local:
 
 clean-local:
        rm -rf _build
-       rm -f ext/refcounting.pyc changes.rst
+       rm -f ext/refcounting.pyc