Use the correct number of parens in JANSSON_VERSION_HEX macro
[jansson.git] / src / Makefile.am
index 3ba8b8b..4f2a58d 100644 (file)
@@ -1,20 +1,25 @@
-include_HEADERS = jansson.h
+include_HEADERS = jansson.h jansson_config.h
 
 lib_LTLIBRARIES = libjansson.la
 libjansson_la_SOURCES = \
        dump.c \
+       error.c \
        hashtable.c \
        hashtable.h \
        jansson_private.h \
        load.c \
+       memory.c \
+       pack_unpack.c \
        strbuffer.c \
        strbuffer.h \
        utf.c \
        utf.h \
-       util.h \
        value.c
 libjansson_la_LDFLAGS = \
        -export-symbols-regex '^json_' \
-       -version-info 1:1:1
+       -version-info 4:0:0
 
-AM_CFLAGS = -Wall -Wextra -Werror
+if GCC
+# These flags are gcc specific
+AM_CFLAGS = -Wall -Wextra -Wdeclaration-after-statement -Werror
+endif