Add spec file
[jansson.git] / test / Makefile.am
index ce169ae..86d1614 100644 (file)
@@ -1,13 +1,10 @@
-SUBDIRS = testprogs
+SUBDIRS = bin suites
+EXTRA_DIST = scripts run-suites
 
-check_PROGRAMS = loadf_dumpf loads_dumps load_file_dump_file
-
-AM_CPPFLAGS = -I$(top_srcdir)/src
-AM_CFLAGS = -Wall -Werror
-LDFLAGS = -static  # for speed and Valgrind
-LDADD = ../src/libjansson.la
-
-TESTS = test-api test-invalid test-valid
+TESTS = run-suites
+TESTS_ENVIRONMENT = \
+       top_srcdir=$(top_srcdir) \
+       top_builddir=$(top_builddir)
 
 clean-local:
-       rm -rf testlogs
+       rm -rf logs