test: Add Makefile.am to test/testprogs
[jansson.git] / test / Makefile.am
index 132c133..ce169ae 100644 (file)
@@ -1,7 +1,13 @@
-check_PROGRAMS = load_dump loadf_dumpf loadfd_dumpfd loads_dumps
+SUBDIRS = testprogs
+
+check_PROGRAMS = loadf_dumpf loads_dumps load_file_dump_file
 
 AM_CPPFLAGS = -I$(top_srcdir)/src
 AM_CFLAGS = -Wall -Werror
+LDFLAGS = -static  # for speed and Valgrind
 LDADD = ../src/libjansson.la
 
-TESTS = test-invalid test-valid
+TESTS = test-api test-invalid test-valid
+
+clean-local:
+       rm -rf testlogs