Merge branch '1.1'
[jansson.git] / test / Makefile.am
index 16c5fd2..ed11110 100644 (file)
@@ -1,3 +1,6 @@
+DIST_SUBDIRS = testprogs testdata
+SUBDIRS = testprogs
+
 check_PROGRAMS = loadf_dumpf loads_dumps load_file_dump_file
 
 AM_CPPFLAGS = -I$(top_srcdir)/src
@@ -5,7 +8,15 @@ AM_CFLAGS = -Wall -Werror
 LDFLAGS = -static  # for speed and Valgrind
 LDADD = ../src/libjansson.la
 
-TESTS = test-invalid test-valid
+TESTS = test-api test-invalid test-valid
+
+EXTRA_DIST = \
+       test-api \
+       test-invalid \
+       test-valid \
+       run-test \
+       json-compare.py \
+       split-testfile.py
 
 clean-local:
        rm -rf testlogs