Refactor the test system
[jansson.git] / test / suites / api / Makefile.am
similarity index 71%
rename from test/testprogs/Makefile.am
rename to test/suites/api/Makefile.am
index 308b9a5..ac83ed1 100644 (file)
@@ -1,4 +1,10 @@
-check_PROGRAMS = test_array test_dump test_load test_simple test_number test_object
+check_PROGRAMS = \
+       test_array \
+       test_dump \
+       test_load \
+       test_simple \
+       test_number \
+       test_object
 
 test_array_SOURCES = test_array.c util.h
 test_dump_SOURCES = test_dump.c util.h
@@ -10,4 +16,4 @@ test_object_SOURCES = test_object.c util.h
 AM_CPPFLAGS = -I$(top_srcdir)/src
 AM_CFLAGS = -Wall -Werror
 LDFLAGS = -static  # for speed and Valgrind
-LDADD = ../../src/libjansson.la
+LDADD = $(top_builddir)/src/libjansson.la