Add custom memory allocation
[jansson.git] / test / suites / api / Makefile.am
index a2829e1..0021f93 100644 (file)
@@ -1,15 +1,28 @@
+EXTRA_DIST = run
+
 check_PROGRAMS = \
        test_array \
+       test_copy \
+       test_dump \
+       test_equal \
        test_load \
-       test_simple \
+       test_memory_funcs \
        test_number \
-       test_object
+       test_object \
+       test_pack \
+       test_simple \
+       test_unpack
 
 test_array_SOURCES = test_array.c util.h
+test_copy_SOURCES = test_copy.c util.h
+test_dump_SOURCES = test_dump.c util.h
 test_load_SOURCES = test_load.c util.h
-test_simple_SOURCES = test_simple.c util.h
+test_memory_funcs_SOURCES = test_memory_funcs.c util.h
 test_number_SOURCES = test_number.c util.h
 test_object_SOURCES = test_object.c util.h
+test_pack_SOURCES = test_pack.c util.h
+test_simple_SOURCES = test_simple.c util.h
+test_unpack_SOURCES = test_unpack.c util.h
 
 AM_CPPFLAGS = -I$(top_srcdir)/src
 AM_CFLAGS = -Wall -Werror