Adds json_pack / json_unpack variadic functions.
[jansson.git] / test / suites / api / Makefile.am
index ddeb147..1e4a0bb 100644 (file)
@@ -4,19 +4,23 @@ check_PROGRAMS = \
        test_array \
        test_equal \
        test_copy \
+       test_dump \
        test_load \
        test_simple \
        test_number \
        test_object \
-       test_cpp
+       test_pack \
+       test_unpack
 
 test_array_SOURCES = test_array.c util.h
 test_copy_SOURCES = test_copy.c util.h
+test_dump_SOURCES = test_dump.c util.h
 test_load_SOURCES = test_load.c util.h
 test_simple_SOURCES = test_simple.c util.h
 test_number_SOURCES = test_number.c util.h
 test_object_SOURCES = test_object.c util.h
-test_cpp_SOURCES = test_cpp.cpp
+test_pack_SOURCES = test_pack.c util.h
+test_unpack_SOURCES = test_unpack.c util.h
 
 AM_CPPFLAGS = -I$(top_srcdir)/src
 AM_CFLAGS = -Wall -Werror