Merge branch 'moonshot' into debian
[libradsec.git] / lib / Makefile.am
index 44f9f02..d5b2bff 100644 (file)
@@ -1,12 +1,26 @@
 AUTOMAKE_OPTIONS = foreign
 ACLOCAL_AMFLAGS = -I m4
 
-SUBDIRS = radius include . examples
-DIST_SUBDIRS=tests ${SUBDIRS}
+# Shared library interface version, i.e. -version-info to Libtool,
+# expressed as three integers CURRENT:REVISION:AGE.
+#
+# CURRENT is the version number of the current interface. Increment
+# CURRENT when the library interface has changed or has been extended.
+#
+# REVISION is the version number of the _implementation_ of the
+# CURRENT interface. Set REVISION to 0 when CURRENT changes, else
+# increment.
+#
+# AGE is the number of interfaces this library implements, i.e. how
+# many versions before CURRENT that are supported. Increment AGE when
+# the library interface is _extended_. Set AGE to 0 when the library
+# interface is _changed_.
 
-INCLUDES = -I$(srcdir)/include -I$(srcdir)/radsecproxy-includes
+SUBDIRS = radius radsecproxy include . examples
+DIST_SUBDIRS = $(SUBDIRS) tests
 
-AM_CFLAGS = -Wall -g
+INCLUDES = -I$(srcdir)/include
+AM_CFLAGS = -Wall -Werror -g
 
 lib_LTLIBRARIES = libradsec.la
 
@@ -24,39 +38,34 @@ libradsec_la_SOURCES = \
        request.c \
        send.c \
        tcp.c \
-       udp.c
-
-libradsec_la_SOURCES += \
-       rsp_debug.c \
-       rsp_hash.c \
-       rsp_list.c \
-       rsp_util.c
+       udp.c \
+       util.c
 
 if RS_ENABLE_TLS
-libradsec_la_SOURCES += \
-       tls.c \
-       rsp_tlscommon.c
+libradsec_la_SOURCES += tls.c
+else
+libradsec_la_SOURCES += md5.c
 endif
 
-libradsec_la_SOURCES += compat.h \
+libradsec_la_SOURCES += \
+       compat.h \
        conn.h \
        debug.h \
        err.h \
        event.h \
+       md5.h \
        packet.h \
        peer.h \
-       rsp_debug.h\
-       rsp_hash.h \
-       rsp_list.h \
-       rsp_tlscommon.h \
-       rsp_util.h \
+       radsec.h \
        tcp.h \
        tls.h \
-       include/radsec/radius.h \
-       udp.h
+       udp.h \
+       util.h
 
-libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
-libradsec_la_CFLAGS = $(AM_CFLAGS) -I. -I./include -Werror # -DDEBUG -DDEBUG_LEVENT 
+EXTRA_DIST = HACKING LICENSE libradsec.spec radsec.sym
+EXTRA_libradsec_la_DEPENDENCIES = radsec.sym
+AM_DISTCHECK_CONFIGURE_FLAGS = --enable-tls --enable-tls-psk
 
-EXTRA_DIST = libradsec.spec radsec.sym
-libradsec_la_LIBADD = radius/libradsec-radius.la
+libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
+libradsec_la_LDFLAGS = -version-info 1:0:1 -export-symbols $(srcdir)/radsec.sym
+libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT