Revive radsecproxy.h and hostport_types.h and move rsp_* into radsecproxy/.
[libradsec.git] / lib / Makefile.am
index 89e6958..08ace0c 100644 (file)
@@ -1,7 +1,23 @@
 AUTOMAKE_OPTIONS = foreign
 ACLOCAL_AMFLAGS = -I m4
 
-SUBDIRS = . examples include 
+# Shared library interface version, i.e. -version-info to Libtool,
+# expressed as three integers CURRENT:REVISION:AGE.
+
+# CURRENT is the version number of the current interface.  Increment
+#        CURRENT when the library interface changes.
+
+# REVISION is the version number of the _implementation_ of the
+#          CURRENT interface.  Set REVISION to 0 when CURRENT changes,
+#          else increment.
+
+# AGE is the number of interfaces this library implements, i.e. how
+#     many versions before CURRENT that are supported.  Increment AGE
+#     when the library interface is _extended_.  Set AGE to 0 when the
+#     library interface is _changed_.
+
+
+SUBDIRS = radius radsecproxy . include examples
 
 INCLUDES = -I$(srcdir)/include
 AM_CFLAGS = -Wall -g
@@ -9,6 +25,7 @@ AM_CFLAGS = -Wall -g
 lib_LTLIBRARIES = libradsec.la
 
 libradsec_la_SOURCES = \
+       avp.c \
        compat.c \
        conf.c \
        conn.c \
@@ -21,19 +38,16 @@ libradsec_la_SOURCES = \
        request.c \
        send.c \
        tcp.c \
-       udp.c
-
-libradsec_la_SOURCES += \
-       rsp_debug.c \
-       rsp_hash.c \
-       rsp_list.c \
-       rsp_util.c
+       udp.c \
+       util.c
 
 if RS_ENABLE_TLS
 libradsec_la_SOURCES += \
-       tls.c \
-       rsp_tlscommon.c
+       tls.c
 endif
 
-libradsec_la_LDFLAGS = -version-info 0:0:0
-libradsec_la_CFLAGS = $(AM_CFLAGS) -Werror # -DDEBUG -DDEBUG_LEVENT 
+EXTRA_DIST = HACKING LICENSE
+
+libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
+libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
+libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT