Merge remote branch 'origin/libradsec-new-client' into HEAD
[libradsec.git] / lib / Makefile.am
index 51aebf9..791c6d5 100644 (file)
@@ -1,7 +1,9 @@
 AUTOMAKE_OPTIONS = foreign
 ACLOCAL_AMFLAGS = -I m4
 
-SUBDIRS = radius . include examples
+SUBDIRS = . examples include radius
+DIST_SUBDIRS=tests ${SUBDIRS}
+
 
 INCLUDES = -I$(srcdir)/include
 AM_CFLAGS = -Wall -g
@@ -36,6 +38,24 @@ libradsec_la_SOURCES += \
        rsp_tlscommon.c
 endif
 
-libradsec_la_LIBADD = radius/libradsec-radius.la
+libradsec_la_SOURCES += compat.h \
+       conn.h \
+       debug.h \
+       err.h \
+       event.h \
+       packet.h \
+       peer.h \
+       rsp_debug.h\
+       rsp_hash.h \
+       rsp_list.h \
+       rsp_tlscommon.h \
+       rsp_util.h \
+       tcp.h \
+       tls.h \
+       udp.h
+
 libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
-libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT 
+libradsec_la_CFLAGS = $(AM_CFLAGS) -I. -I./include -Werror # -DDEBUG -DDEBUG_LEVENT 
+
+EXTRA_DIST = libradsec.spec radsec.sym
+libradsec_la_LIBADD = radius/libradsec-radius.la