Add md5.[ch] for when we are configured without OpenSSL.
[libradsec.git] / lib / Makefile.am
index 294f04e..9415c3d 100644 (file)
@@ -17,7 +17,7 @@ ACLOCAL_AMFLAGS = -I m4
 #     library interface is _changed_.
 
 
-SUBDIRS = . examples include 
+SUBDIRS = radius radsecproxy . include examples
 
 INCLUDES = -I$(srcdir)/include
 AM_CFLAGS = -Wall -g
@@ -25,6 +25,7 @@ AM_CFLAGS = -Wall -g
 lib_LTLIBRARIES = libradsec.la
 
 libradsec_la_SOURCES = \
+       avp.c \
        compat.c \
        conf.c \
        conn.c \
@@ -37,19 +38,17 @@ libradsec_la_SOURCES = \
        request.c \
        send.c \
        tcp.c \
-       udp.c
-
-libradsec_la_SOURCES += \
-       rsp_debug.c \
-       rsp_hash.c \
-       rsp_list.c \
-       rsp_util.c
+       udp.c \
+       util.c
 
 if RS_ENABLE_TLS
-libradsec_la_SOURCES += \
-       tls.c \
-       rsp_tlscommon.c
+libradsec_la_SOURCES += tls.c
+else
+libradsec_la_SOURCES += md5.c
 endif
 
+EXTRA_DIST = HACKING LICENSE
+
+libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
 libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
-libradsec_la_CFLAGS = $(AM_CFLAGS) -Werror # -DDEBUG -DDEBUG_LEVENT 
+libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT