Initial RPM packaging
[libradsec.git] / lib / Makefile.am
index a26750d..9d8249c 100644 (file)
@@ -2,6 +2,7 @@ AUTOMAKE_OPTIONS = foreign
 ACLOCAL_AMFLAGS = -I m4
 
 SUBDIRS = . examples include 
+DIST_SUBDIRS=tests ${SUBDIRS}
 
 INCLUDES = -I$(srcdir)/include
 AM_CFLAGS = -Wall -g
@@ -35,5 +36,23 @@ libradsec_la_SOURCES += \
        rsp_tlscommon.c
 endif
 
+libradsec_la_SOURCES += compat.h \
+       conn.h \
+       debug.h \
+       err.h \
+       event.h \
+       packet.h \
+       peer.h \
+       rsp_debug.h\
+       rsp_hash.h \
+       rsp_list.h \
+       rsp_tlscommon.h \
+       rsp_util.h \
+       tcp.h \
+       tls.h \
+       udp.h
+
 libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
 libradsec_la_CFLAGS = $(AM_CFLAGS) -Werror # -DDEBUG -DDEBUG_LEVENT 
+
+EXTRA_DIST = libradsec.spec radsec.sym