Enable TLS by default, configure time.
[libradsec.git] / lib / configure.ac
index 4abd170..f8aabde 100644 (file)
@@ -1,6 +1,6 @@
 # -*- Autoconf -*- script for libradsec.
 
-AC_PREREQ([2.65])
+AC_PREREQ([2.63])
 AC_INIT([libradsec], [0.0.4.dev], [linus+libradsec@nordu.net])
 AC_CONFIG_MACRO_DIR([m4])
 AC_CONFIG_SRCDIR([radsec.c])
@@ -22,7 +22,8 @@ AC_CHECK_LIB([event_core], [event_get_version],,
 ## Enable TLS (RadSec).
 AH_TEMPLATE([RS_ENABLE_TLS], [TLS (RadSec) enabled])
 AH_TEMPLATE([RADPROT_TLS], [])  dnl Legacy.
-AC_ARG_ENABLE([tls], AS_HELP_STRING([--enable-tls], [enable TLS (RadSec)]),
+AC_ARG_ENABLE([tls], AS_HELP_STRING([--disable-tls], [disable TLS (RadSec)]),
+    [],
     [AC_CHECK_LIB([event_openssl], [bufferevent_openssl_socket_new],,
          AC_MSG_ERROR([required library event_openssl not found]))
      AC_DEFINE([RS_ENABLE_TLS])
@@ -53,10 +54,10 @@ AC_TYPE_UINT8_T
 # Checks for library functions.
 AC_CHECK_FUNCS([memset socket strdup strerror strrchr])
 
-AC_CONFIG_FILES([Makefile
+AC_CONFIG_FILES([Makefile libradsec.spec
                  radsecproxy/Makefile
-                radius/Makefile
-                include/Makefile
+                 radius/Makefile
+                 include/Makefile
                  examples/Makefile
                  tests/Makefile])
 AC_OUTPUT