Don't use deprecated 'INCLUDES' variable in Makefile.am files.
[libradsec.git] / lib / radius / Makefile.am
index 92a12cf..462a1e0 100644 (file)
@@ -1,7 +1,7 @@
 AUTOMAKE_OPTIONS = foreign
 ACLOCAL_AMFLAGS = -I m4
 
-INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)
 AM_CFLAGS = -Wall -g
 
 noinst_LTLIBRARIES = libradsec-radius.la
@@ -18,13 +18,18 @@ libradsec_radius_la_SOURCES = \
        static.c \
        valuepair.c
 
+libradsec_radius_la_SOURCES += client.h
+
 libradsec_radius_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H
 
 DICTIONARIES = \
        share/dictionary.txt \
        share/dictionary.juniper \
        share/dictionary.microsoft \
-       share/dictionary.ukerna
+       share/dictionary.ukerna \
+       share/dictionary.abfab.ietf
+
+EXTRA_DIST = dictionaries.c $(DICTIONARIES) common.pl convert.pl
 
 $(top_srcdir)/include/radsec/radius.h dictionaries.c: ${DICTIONARIES} convert.pl common.pl
        $(srcdir)/convert.pl ${DICTIONARIES}
@@ -35,4 +40,3 @@ clean-local:
        rm -f dictionaries.c
 
 $(libradsec_radius_la_SOURCES): $(top_srcdir)/include/radsec/radius.h
-