Don't use deprecated 'INCLUDES' variable in Makefile.am files.
[libradsec.git] / lib / tests / Makefile.am
index 7c5408b..09f9d28 100644 (file)
@@ -1,12 +1,12 @@
 AUTOMAKE_OPTIONS = foreign
-INCLUDES = -I$(top_srcdir)/include
-AM_CFLAGS = -Wall -g
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -Werror -g
 
 TESTS = test-udp
 
 check_PROGRAMS = test-udp udp-server
 
-test_udp_SOURCES = test-udp.c udp.c
-test_udp_LDADD = ../libradsec.la -lcgreen -lm
+test_udp_SOURCES = test-udp.c udp.c udp.h
+test_udp_LDADD = ../libradsec.la -lcunit -lm
 
-udp_server_SOURCES = udp-server.c udp.c
+udp_server_SOURCES = udp-server.c udp.c udp.h