Merge branch 'master' of http://www.project-moonshot.org/git/moonshot
[mech_eap.git] / mech_eap / Makefile.am
index 5f78a77..23de6af 100644 (file)
@@ -1,7 +1,9 @@
 AUTOMAKE_OPTIONS = foreign
 
 EXTRA_DIST = gsseap_err.et radsec_err.et \
-       mech_eap.exports mech_eap-noacceptor.exports 
+       mech_eap.exports mech_eap-noacceptor.exports  radius_ad.exports \
+       LICENSE AUTHORS
+
 
 gssincludedir = $(includedir)/gssapi
 gssinclude_HEADERS = gssapi_eap.h
@@ -33,14 +35,14 @@ mech_eap_la_DEPENDENCIES = $(GSSEAP_EXPORTS)
 
 mech_eap_la_CPPFLAGS = -DBUILD_GSSEAP_LIB -DSYSCONFDIR=\"${sysconfdir}\" -DDATAROOTDIR=\"${datarootdir}\"
 mech_eap_la_CFLAGS   += \
-                       @KRB5_CFLAGS@  @RADSEC_CFLAGS@ @TARGET_CFLAGS@ $(EAP_CFLAGS)
+                       @KRB5_CFLAGS@ @RADSEC_CFLAGS@ @TARGET_CFLAGS@ $(EAP_CFLAGS)
 mech_eap_la_CXXFLAGS += \
-                       @KRB5_CFLAGS@  @RADSEC_CFLAGS@ \
+                       @KRB5_CFLAGS@ @RADSEC_CFLAGS@ \
                        @OPENSAML_CXXFLAGS@ @SHIBRESOLVER_CXXFLAGS@ @SHIBSP_CXXFLAGS@ \
                        @TARGET_CFLAGS@ $(EAP_CFLAGS)
 mech_eap_la_LDFLAGS  = -avoid-version -module \
                        -export-symbols $(GSSEAP_EXPORTS) -no-undefined \
-                       @RADSEC_LDFLAGS@ @TARGET_LDFLAGS@
+                       @KRB5_LDFLAGS@ @RADSEC_LDFLAGS@ @TARGET_LDFLAGS@
 if TARGET_WINDOWS
 mech_eap_la_LDFLAGS += -debug
 endif
@@ -62,6 +64,7 @@ mech_eap_la_SOURCES =                         \
        display_status.c                        \
        duplicate_name.c                        \
        eap_mech.c                              \
+       exchange_meta_data.c                    \
        export_name.c                           \
        export_sec_context.c                    \
        get_mic.c                               \
@@ -82,6 +85,8 @@ mech_eap_la_SOURCES =                         \
        inquire_sec_context_by_oid.c            \
        process_context_token.c                 \
        pseudo_random.c                         \
+       query_mechanism_info.c                  \
+       query_meta_data.c                       \
        radsec_err.c                            \
        release_cred.c                          \
        release_name.c                          \
@@ -99,7 +104,6 @@ mech_eap_la_SOURCES =                        \
        util_krb.c                              \
        util_lucid.c                            \
        util_mech.c                             \
-       util_moonshot.c                         \
        util_name.c                             \
        util_oid.c                              \
        util_ordering.c                         \
@@ -121,6 +125,13 @@ mech_eap_la_SOURCES =                      \
        util_saml.h \
        util_shib.h
 
+if LIBMOONSHOT
+mech_eap_la_SOURCES += util_moonshot.c
+mech_eap_la_CFLAGS  += @LIBMOONSHOT_CFLAGS@
+mech_eap_la_LDFLAGS += @LIBMOONSHOT_LDFLAGS@
+mech_eap_la_LIBADD  += @LIBMOONSHOT_LIBS@
+endif
+
 
 if GSSEAP_ENABLE_ACCEPTOR