Merge branch 'master' of http://www.project-moonshot.org/git/moonshot
[mech_eap.git] / mech_eap / Makefile.am
index 608f339..23de6af 100644 (file)
@@ -1,7 +1,9 @@
 AUTOMAKE_OPTIONS = foreign
 
 EXTRA_DIST = gsseap_err.et radsec_err.et \
-       mech_eap.exports mech_eap-noacceptor.exports 
+       mech_eap.exports mech_eap-noacceptor.exports  radius_ad.exports \
+       LICENSE AUTHORS
+
 
 gssincludedir = $(includedir)/gssapi
 gssinclude_HEADERS = gssapi_eap.h
@@ -40,7 +42,7 @@ mech_eap_la_CXXFLAGS += \
                        @TARGET_CFLAGS@ $(EAP_CFLAGS)
 mech_eap_la_LDFLAGS  = -avoid-version -module \
                        -export-symbols $(GSSEAP_EXPORTS) -no-undefined \
-                       @RADSEC_LDFLAGS@ @TARGET_LDFLAGS@
+                       @KRB5_LDFLAGS@ @RADSEC_LDFLAGS@ @TARGET_LDFLAGS@
 if TARGET_WINDOWS
 mech_eap_la_LDFLAGS += -debug
 endif
@@ -130,6 +132,7 @@ mech_eap_la_LDFLAGS += @LIBMOONSHOT_LDFLAGS@
 mech_eap_la_LIBADD  += @LIBMOONSHOT_LIBS@
 endif
 
+
 if GSSEAP_ENABLE_ACCEPTOR
 
 mech_eap_la_SOURCES +=                         \