Fixes for Heimdal (macOS) builds from Stefan.
[mech_eap.git] / mech_eap / Makefile.am
index 145188f..57b7b3a 100644 (file)
@@ -2,7 +2,8 @@ AUTOMAKE_OPTIONS = foreign
 
 EXTRA_DIST = gsseap_err.et radsec_err.et \
        mech_eap.exports mech_eap-noacceptor.exports  radius_ad.exports \
-       LICENSE AUTHORS
+       LICENSE AUTHORS mech \
+       README.samba4 NOTES radsec.conf
 
 
 gssincludedir = $(includedir)/gssapi
@@ -12,9 +13,9 @@ EAP_CFLAGS = -I$(srcdir)/../libeap/src -I$(srcdir)/../libeap/src/common -I$(srcd
        -I$(srcdir)/../libeap/src/utils
 
 if GSSEAP_ENABLE_ACCEPTOR
-GSSEAP_EXPORTS = mech_eap.exports
+GSSEAP_EXPORTS = $(srcdir)/mech_eap.exports
 else
-GSSEAP_EXPORTS = mech_eap-noacceptor.exports
+GSSEAP_EXPORTS = $(srcdir)/mech_eap-noacceptor.exports
 endif
 
 gssdir = $(libdir)/gss
@@ -118,6 +119,7 @@ mech_eap_la_SOURCES =                       \
        wrap_iov.c                              \
        wrap_iov_length.c                       \
        wrap_size_limit.c \
+       gssapi_headerfix.h \
        gssapiP_eap.h \
        util_attr.h \
        util_base64.h \
@@ -173,7 +175,7 @@ krb5plugins_LTLIBRARIES = radius_ad.la
 radius_ad_la_CFLAGS  = -Werror -Wall -Wunused-parameter \
                        @KRB5_CFLAGS@ $(EAP_CFLAGS) @RADSEC_CFLAGS@ @TARGET_CFLAGS@
 radius_ad_la_LDFLAGS = -avoid-version -module \
-                      -export-symbols radius_ad.exports -no-undefined
+                      -export-symbols $(srcdir)/radius_ad.exports -no-undefined
 radius_ad_la_LIBADD  = @KRB5_LIBS@
 radius_ad_la_SOURCES = util_adshim.c authdata_plugin.h
 endif