Simplify configure.ac and makefile.am files
[mod_auth_gssapi.git] / src / Makefile.am
index a725b52..95b85b3 100644 (file)
@@ -1,25 +1,9 @@
-MAG_CFLAGS = @APR_CPPFLAGS@ @APXS_CPPFLAGS@ @APXS_CPPFLAGS_SHLIB@
-MAG_INCLUDES = @INCLTDL@ @APR_INCLUDES@ @APXS_INCLUDES@
-MAG_LIBS = @LIBLTDL@ @APR_LDFLAGS@ @APXS_LDFLAGS@ @APXS_LIBS@ @APXS_LD_SHLIB@
-MAG_LIBEXECDIR = @APXS_LIBEXECDIR@
+all-local:
+       @APXS@ -c ${LIBS} ${CFLAGS} mod_auth_gssapi.c
 
-if HAVE_GCC
-    MAG_CFLAGS += -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith \
-                  -Wcast-qual -Wcast-align -Wwrite-strings \
-                  -Werror-implicit-function-declaration \
-                  -fno-strict-aliasing
-endif
-
-lib_LTLIBRARIES = mod_auth_gssapi.la
-
-mod_auth_gssapi_la_LDFLAGS = -module
-
-mod_auth_gssapi.la: mod_auth_gssapi.c
-       @APXS@ -c ${LIBS} -Wc,"${MAG_CFLAGS} ${MAG_INCLUDES}" -Wl,"${MAG_LIBS}" mod_auth_gssapi.c
-
-install: mod_auth_gssapi.la
-       if test ! -d ${MAG_LIBEXECDIR}; then mkdir -p ${MAG_LIBEXECDIR}; fi
-       @APXS@ -i -S LIBEXECDIR=${MAG_LIBEXECDIR} mod_auth_gssapi.la
+install-exec-local:
+       if test ! -d ${APXS_LIBEXECDIR}; then mkdir -p ${APXS_LIBEXECDIR}; fi
+       @APXS@ -i -S LIBEXECDIR=${APXS_LIBEXECDIR} mod_auth_gssapi.la
 
 clean-local:
        rm -f mod_auth_gssapi.slo mod_auth_gssapi.la mod_auth_gssapi.lo .libs