Merge branch 'master' of http://www.project-moonshot.org/git/moonshot
[moonshot.git] / moonshot / mech_eap / Makefile.am
index ba6e8dd..23de6af 100644 (file)
@@ -1,5 +1,10 @@
 AUTOMAKE_OPTIONS = foreign
 
+EXTRA_DIST = gsseap_err.et radsec_err.et \
+       mech_eap.exports mech_eap-noacceptor.exports  radius_ad.exports \
+       LICENSE AUTHORS
+
+
 gssincludedir = $(includedir)/gssapi
 gssinclude_HEADERS = gssapi_eap.h
 
@@ -26,17 +31,18 @@ OS_LIBS =
 mech_eap_la_CFLAGS   = -Werror -Wall -Wunused-parameter
 mech_eap_la_CXXFLAGS = -Werror -Wall -Wunused-parameter
 endif
+mech_eap_la_DEPENDENCIES = $(GSSEAP_EXPORTS)
 
 mech_eap_la_CPPFLAGS = -DBUILD_GSSEAP_LIB -DSYSCONFDIR=\"${sysconfdir}\" -DDATAROOTDIR=\"${datarootdir}\"
-mech_eap_la_CFLAGS   = -Werror -Wall -Wunused-parameter \
-                       @KRB5_CFLAGS@  @RADSEC_CFLAGS@ @TARGET_CFLAGS@ $(EAP_CFLAGS)
-mech_eap_la_CXXFLAGS = -Werror -Wall -Wunused-parameter \
-                       @KRB5_CFLAGS@  @RADSEC_CFLAGS@ \
+mech_eap_la_CFLAGS   += \
+                       @KRB5_CFLAGS@ @RADSEC_CFLAGS@ @TARGET_CFLAGS@ $(EAP_CFLAGS)
+mech_eap_la_CXXFLAGS += \
+                       @KRB5_CFLAGS@ @RADSEC_CFLAGS@ \
                        @OPENSAML_CXXFLAGS@ @SHIBRESOLVER_CXXFLAGS@ @SHIBSP_CXXFLAGS@ \
                        @TARGET_CFLAGS@ $(EAP_CFLAGS)
 mech_eap_la_LDFLAGS  = -avoid-version -module \
                        -export-symbols $(GSSEAP_EXPORTS) -no-undefined \
-                       @RADSEC_LDFLAGS@ @TARGET_LDFLAGS@
+                       @KRB5_LDFLAGS@ @RADSEC_LDFLAGS@ @TARGET_LDFLAGS@
 if TARGET_WINDOWS
 mech_eap_la_LDFLAGS += -debug
 endif
@@ -58,6 +64,7 @@ mech_eap_la_SOURCES =                         \
        display_status.c                        \
        duplicate_name.c                        \
        eap_mech.c                              \
+       exchange_meta_data.c                    \
        export_name.c                           \
        export_sec_context.c                    \
        get_mic.c                               \
@@ -73,12 +80,13 @@ mech_eap_la_SOURCES =                       \
        inquire_cred_by_oid.c                   \
        inquire_mech_for_saslname.c             \
        inquire_mechs_for_name.c                \
-       inquire_name.c                          \
        inquire_names_for_mech.c                \
        inquire_saslname_for_mech.c             \
        inquire_sec_context_by_oid.c            \
        process_context_token.c                 \
        pseudo_random.c                         \
+       query_mechanism_info.c                  \
+       query_meta_data.c                       \
        radsec_err.c                            \
        release_cred.c                          \
        release_name.c                          \
@@ -96,7 +104,6 @@ mech_eap_la_SOURCES =                        \
        util_krb.c                              \
        util_lucid.c                            \
        util_mech.c                             \
-       util_moonshot.c                         \
        util_name.c                             \
        util_oid.c                              \
        util_ordering.c                         \
@@ -107,7 +114,24 @@ mech_eap_la_SOURCES =                      \
        wrap.c                                  \
        wrap_iov.c                              \
        wrap_iov_length.c                       \
-       wrap_size_limit.c
+       wrap_size_limit.c \
+       gssapiP_eap.h \
+       util_attr.h \
+       util_base64.h \
+       util.h \
+       util_json.h \
+       util_radius.h \
+       util_reauth.h \
+       util_saml.h \
+       util_shib.h
+
+if LIBMOONSHOT
+mech_eap_la_SOURCES += util_moonshot.c
+mech_eap_la_CFLAGS  += @LIBMOONSHOT_CFLAGS@
+mech_eap_la_LDFLAGS += @LIBMOONSHOT_LDFLAGS@
+mech_eap_la_LIBADD  += @LIBMOONSHOT_LIBS@
+endif
+
 
 if GSSEAP_ENABLE_ACCEPTOR
 
@@ -116,6 +140,7 @@ mech_eap_la_SOURCES +=                              \
        delete_name_attribute.c                 \
        export_name_composite.c                 \
        get_name_attribute.c                    \
+       inquire_name.c                          \
        map_name_to_any.c                       \
        release_any_name_mapping.c              \
        set_name_attribute.c                    \
@@ -134,7 +159,7 @@ endif
 
 endif
 
-BUILT_SOURCES = gsseap_err.c radsec_err.c
+BUILT_SOURCES = gsseap_err.c radsec_err.c gsseap_err.h radsec_err.h
 
 if GSSEAP_ENABLE_REAUTH
 mech_eap_la_SOURCES += util_reauth.c
@@ -148,7 +173,7 @@ radius_ad_la_CFLAGS  = -Werror -Wall -Wunused-parameter \
 radius_ad_la_LDFLAGS = -avoid-version -module \
                       -export-symbols radius_ad.exports -no-undefined
 radius_ad_la_LIBADD  = @KRB5_LIBS@
-radius_ad_la_SOURCES = util_adshim.c
+radius_ad_la_SOURCES = util_adshim.c authdata_plugin.h
 endif
 endif