Merge branch 'libradsec-add-avp-2' into libradsec
[radsecproxy.git] / lib / Makefile.am
index ab1a47e..769e7ab 100644 (file)
@@ -3,21 +3,22 @@ ACLOCAL_AMFLAGS = -I m4
 
 # Shared library interface version, i.e. -version-info to Libtool,
 # expressed as three integers CURRENT:REVISION:AGE.
-
-# CURRENT is the version number of the current interface.  Increment
-#        CURRENT when the library interface changes.
-
+#
+# CURRENT is the version number of the current interface. Increment
+# CURRENT when the library interface has changed or has been extended.
+#
 # REVISION is the version number of the _implementation_ of the
-#          CURRENT interface.  Set REVISION to 0 when CURRENT changes,
-#          else increment.
-
+# CURRENT interface. Set REVISION to 0 when CURRENT changes, else
+# increment.
+#
 # AGE is the number of interfaces this library implements, i.e. how
-#     many versions before CURRENT that are supported.  Increment AGE
-#     when the library interface is _extended_.  Set AGE to 0 when the
-#     library interface is _changed_.
+# many versions before CURRENT that are supported. Increment AGE when
+# the library interface is _extended_. Set AGE to 0 when the library
+# interface is _changed_.
 
 
 SUBDIRS = radius radsecproxy include . examples
+DIST_SUBDIRS = $(SUBDIRS) tests
 
 INCLUDES = -I$(srcdir)/include
 AM_CFLAGS = -Wall -Werror -g
@@ -47,8 +48,24 @@ else
 libradsec_la_SOURCES += md5.c
 endif
 
-EXTRA_DIST = HACKING LICENSE
+libradsec_la_SOURCES += \
+       compat.h \
+       conn.h \
+       debug.h \
+       err.h \
+       event.h \
+       md5.h \
+       packet.h \
+       peer.h \
+       radsec.h \
+       tcp.h \
+       tls.h \
+       udp.h \
+       util.h
+
+EXTRA_DIST = HACKING LICENSE libradsec.spec radsec.sym
+AM_DISTCHECK_CONFIGURE_FLAGS = --enable-tls --enable-tls-psk
 
 libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
-libradsec_la_LDFLAGS = -version-info 1:0:1 -export-symbols radsec.sym
+libradsec_la_LDFLAGS = -version-info 1:0:1 -export-symbols $(srcdir)/radsec.sym
 libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT