Bump library interface revision.
[radsecproxy.git] / lib / Makefile.am
index 9acc2cb..294f04e 100644 (file)
@@ -1,18 +1,55 @@
 AUTOMAKE_OPTIONS = foreign
 ACLOCAL_AMFLAGS = -I m4
 
+# Shared library interface version, i.e. -version-info to Libtool,
+# expressed as three integers CURRENT:REVISION:AGE.
+
+# CURRENT is the version number of the current interface.  Increment
+#        CURRENT when the library interface changes.
+
+# REVISION is the version number of the _implementation_ of the
+#          CURRENT interface.  Set REVISION to 0 when CURRENT changes,
+#          else increment.
+
+# AGE is the number of interfaces this library implements, i.e. how
+#     many versions before CURRENT that are supported.  Increment AGE
+#     when the library interface is _extended_.  Set AGE to 0 when the
+#     library interface is _changed_.
+
+
 SUBDIRS = . examples include 
 
 INCLUDES = -I$(srcdir)/include
+AM_CFLAGS = -Wall -g
 
 lib_LTLIBRARIES = libradsec.la
+
 libradsec_la_SOURCES = \
-       attr.c \
+       compat.c \
        conf.c \
+       conn.c \
        debug.c \
        err.c \
+       event.c \
        packet.c \
+       peer.c \
+       radsec.c \
        request.c \
-       radsec.c
-libradsec_la_LDFLAGS = -version-info 0:0:0
-libradsec_la_CFLAGS = $(CFLAGS) -DDEBUG -DDEBUG_LEVENT
+       send.c \
+       tcp.c \
+       udp.c
+
+libradsec_la_SOURCES += \
+       rsp_debug.c \
+       rsp_hash.c \
+       rsp_list.c \
+       rsp_util.c
+
+if RS_ENABLE_TLS
+libradsec_la_SOURCES += \
+       tls.c \
+       rsp_tlscommon.c
+endif
+
+libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
+libradsec_la_CFLAGS = $(AM_CFLAGS) -Werror # -DDEBUG -DDEBUG_LEVENT