Revamping for listeners.
[radsecproxy.git] / lib / Makefile.am
index 06ea8d5..6d62c97 100644 (file)
@@ -3,19 +3,22 @@ ACLOCAL_AMFLAGS = -I m4
 
 # Shared library interface version, i.e. -version-info to Libtool,
 # expressed as three integers CURRENT:REVISION:AGE.
-
-# CURRENT is the version number of the current interface.  Increment
-#        CURRENT when the library interface changes.
-
+#
+# CURRENT is the version number of the current interface.
+# Increment CURRENT when the library interface changes.
+#
 # REVISION is the version number of the _implementation_ of the
-#          CURRENT interface.  Set REVISION to 0 when CURRENT changes,
-#          else increment.
-
+# CURRENT interface.
+# Set REVISION to 0 when CURRENT changes, else increment.
+#
 # AGE is the number of interfaces this library implements, i.e. how
-#     many versions before CURRENT that are supported.  Increment AGE
-#     when the library interface is _extended_.  Set AGE to 0 when the
-#     library interface is _changed_.
+# many versions before CURRENT that are supported.
+# Increment AGE when the library interface is _extended_.
+# Set AGE to 0 when the library interface is _changed_.
 
+VER_CUR = 1
+VER_REV = 0
+VER_AGE = 0
 
 SUBDIRS = radius radsecproxy . include examples
 
@@ -44,13 +47,19 @@ libradsec_la_SOURCES = \
        util.c
 
 if RS_ENABLE_TLS
-libradsec_la_SOURCES += tls.c
+  libradsec_la_SOURCES += tls.c
 else
-libradsec_la_SOURCES += md5.c
+  libradsec_la_SOURCES += md5.c
 endif
 
 EXTRA_DIST = HACKING LICENSE
 
-libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
-libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
-libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT 
+libradsec_la_CFLAGS = \
+       $(AM_CFLAGS) -DHAVE_CONFIG_H \
+       -DDEBUG -DDEBUG_LEVENT
+libradsec_la_LDFLAGS = \
+       -version-info $(VER_CUR):$(VER_REV):$(VER_AGE) \
+       -export-symbols radsec.sym
+libradsec_la_LIBADD = \
+       radsecproxy/libradsec-radsecproxy.la \
+       radius/libradsec-radius.la