Merge remote branch 'origin/libradsec-new-client' into HEAD
[radsecproxy.git] / lib / configure.ac
index 0df726d..0602f03 100644 (file)
@@ -17,8 +17,6 @@ AC_CHECK_LIB([confuse], [cfg_init],,
     AC_MSG_ERROR([required library libconfuse not found]))
 AC_CHECK_LIB([event_core], [event_get_version],,
     AC_MSG_ERROR([required library libevent_core not found]))
-AC_CHECK_LIB([freeradius-radius], [rad_alloc],,
-    AC_MSG_ERROR([required library libfreeradius-radius not found]))
 
 # Enable-knobs.
 AH_TEMPLATE([RS_ENABLE_TLS], [TLS (RadSec) enabled])
@@ -32,7 +30,8 @@ AM_CONDITIONAL([RS_ENABLE_TLS], [test "${enable_tls+set}" = set])
 
 # Checks for header files.
 AC_CHECK_HEADERS(
-    [netdb.h netinet/in.h stdint.h stdlib.h string.h sys/socket.h unistd.h])
+    [sys/time.h time.h netdb.h netinet/in.h stdint.h stdlib.h strings.h string.h \
+     sys/socket.h unistd.h syslog.h sys/select.h fcntl.h arpa/inet.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_TYPE_SIZE_T
@@ -42,7 +41,7 @@ AC_TYPE_UINT8_T
 # Checks for library functions.
 AC_CHECK_FUNCS([memset socket strdup strerror strrchr])
 
-AC_CONFIG_FILES([Makefile libradsec.spec
+AC_CONFIG_FILES([Makefile libradsec.spec radius/Makefile
                 include/Makefile
                  examples/Makefile
                  tests/Makefile])