Makefile and specfile changes for SuSE.
[shibboleth/cpp-opensaml.git] / doc / Makefile.am
index db6bd81..2c53926 100644 (file)
@@ -1,9 +1,13 @@
 AUTOMAKE_OPTIONS = foreign
 
-pkgdocdir = $(datadir)/doc/@PACKAGE@
+pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
+
+install-data-hook:
+       cp -r api $(DESTDIR)$(pkgdocdir)
+       rm -rf `find $(DESTDIR)$(pkgdocdir)/api -name .svn`
 
 docfiles = \
-    README.txt \
+       README.txt \
        LICENSE.txt \
        NOTICE.txt \
        LOG4CPP.LICENSE
@@ -11,4 +15,3 @@ docfiles = \
 pkgdoc_DATA = $(docfiles)
 
 EXTRA_DIST = $(docfiles) api
-       
\ No newline at end of file