Remove api directory from dist.
[shibboleth/cpp-opensaml.git] / doc / Makefile.am
index a2f58c2..7e988ee 100644 (file)
@@ -1,9 +1,18 @@
-AUTOMAKE_OPTIONS = foreign\r
-\r
-pkgdocdir = $(prefix)/doc/@PACKAGE@\r
-\r
-pkgdoc_DATA = \\r
-       LICENSE.txt \\r
-       NOTICE.txt \\r
-       LOG4CPP.LICENSE \\r
-       CURL.LICENSE\r
+AUTOMAKE_OPTIONS = foreign
+
+pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
+
+install-data-hook:
+       if test -d api ; then \
+               cp -r api $(DESTDIR)$(pkgdocdir); \
+       fi;
+
+docfiles = \
+       README.txt \
+       LICENSE.txt \
+       NOTICE.txt \
+       LOG4CPP.LICENSE
+
+pkgdoc_DATA = $(docfiles)
+
+EXTRA_DIST = $(docfiles)