Remove api directory from dist.
[shibboleth/cpp-opensaml.git] / doc / Makefile.am
index ae479f6..7e988ee 100644 (file)
@@ -1,8 +1,14 @@
 AUTOMAKE_OPTIONS = foreign
 
-pkgdocdir = $(datadir)/doc/@PACKAGE@
+pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
+
+install-data-hook:
+       if test -d api ; then \
+               cp -r api $(DESTDIR)$(pkgdocdir); \
+       fi;
 
 docfiles = \
+       README.txt \
        LICENSE.txt \
        NOTICE.txt \
        LOG4CPP.LICENSE
@@ -10,4 +16,3 @@ docfiles = \
 pkgdoc_DATA = $(docfiles)
 
 EXTRA_DIST = $(docfiles)
-       
\ No newline at end of file