Multi-line svn commit, see body.
[shibboleth/cpp-opensaml.git] / saml / Makefile.am
index 2bb57f2..10fceb9 100644 (file)
@@ -90,6 +90,7 @@ saml2mdinclude_HEADERS = \
        saml2/metadata/ChainingMetadataProvider.h \
        saml2/metadata/EndpointManager.h \
        saml2/metadata/Metadata.h \
+       saml2/metadata/MetadataCredentialContext.h \
        saml2/metadata/MetadataCredentialCriteria.h \
        saml2/metadata/MetadataFilter.h \
        saml2/metadata/MetadataProvider.h \
@@ -131,6 +132,7 @@ libsaml_la_SOURCES = \
        saml1/binding/impl/SAML1MessageRule.cpp \
        saml1/profile/AssertionValidator.cpp \
        saml1/profile/BrowserSSOProfileValidator.cpp \
+       saml2/core/impl/Assertions.cpp \
        saml2/core/impl/Assertions20Impl.cpp \
        saml2/core/impl/Assertions20SchemaValidators.cpp \
        saml2/core/impl/Protocols20Impl.cpp \
@@ -157,8 +159,8 @@ libsaml_la_SOURCES = \
        saml2/binding/impl/SAML2SOAPEncoder.cpp \
        saml2/binding/impl/SAML2SOAPClient.cpp \
        saml2/binding/impl/SAML2MessageRule.cpp \
-       saml2/profile/AssertionValidator.cpp \
-       saml2/profile/BrowserSSOProfileValidator.cpp \
+       saml2/profile/Assertion20Validator.cpp \
+       saml2/profile/BrowserSSOProfile20Validator.cpp \
        encryption/EncryptedKeyResolver.cpp \
        signature/ContentReference.cpp \
        signature/SignatureProfileValidator.cpp \
@@ -173,4 +175,4 @@ libsaml_la_LDFLAGS = -version-info 2:0:0
 install-exec-hook:
        for la in $(lib_LTLIBRARIES) ; do rm -f $(DESTDIR)$(libdir)/$$la ; done
 
-EXTRA_DIST = saml.vcproj
+EXTRA_DIST = saml.vcproj zlib