Refactored signature handling.
[shibboleth/cpp-opensaml.git] / saml / Makefile.am
index 460c788..4bf8fb3 100644 (file)
@@ -15,14 +15,16 @@ libsamlinclude_HEADERS = \
     SAMLConfig.h
 
 siginclude_HEADERS = \
-    signature/SigningContext.h \
-    signature/VerifyingContext.h
+    signature/ContentReference.h \
+    signature/SignableObject.h \ 
+    signature/SignatureProfileValidator.h
 
 utilinclude_HEADERS = \
     util/SAMLConstants.h
 
 saml1coreinclude_HEADERS = \
-       saml1/core/Assertions.h
+       saml1/core/Assertions.h \
+       saml1/core/Protocols.h
 
 noinst_HEADERS = \
     internal.h
@@ -31,8 +33,10 @@ libsaml_la_SOURCES = \
     SAMLConfig.cpp \
     saml1/core/impl/AssertionsImpl.cpp \
     saml1/core/impl/AssertionsSchemaValidators.cpp \
-    signature/SigningContext.cpp \
-    signature/VerifyingContext.cpp \
+    saml1/core/impl/ProtocolsImpl.cpp \
+    saml1/core/impl/ProtocolsSchemaValidators.cpp \
+    signature/ContentReference.cpp \
+    signature/SignatureProfileValidator.cpp \
     util/SAMLConstants.cpp
 
 # this is different from the project version