Cloning fixes, initial protocol check-in.
[shibboleth/cpp-opensaml.git] / saml / Makefile.am
index 460c788..6171f9f 100644 (file)
@@ -22,7 +22,8 @@ utilinclude_HEADERS = \
     util/SAMLConstants.h
 
 saml1coreinclude_HEADERS = \
-       saml1/core/Assertions.h
+       saml1/core/Assertions.h \
+       saml1/core/Protocols.h
 
 noinst_HEADERS = \
     internal.h
@@ -31,6 +32,8 @@ libsaml_la_SOURCES = \
     SAMLConfig.cpp \
     saml1/core/impl/AssertionsImpl.cpp \
     saml1/core/impl/AssertionsSchemaValidators.cpp \
+    saml1/core/impl/ProtocolsImpl.cpp \
+    saml1/core/impl/ProtocolsSchemaValidators.cpp \
     signature/SigningContext.cpp \
     signature/VerifyingContext.cpp \
     util/SAMLConstants.cpp