Move ReplayCache and StorageService APIs to full build only.
[shibboleth/cpp-opensaml.git] / saml / Makefile.am
index 4453d9f..6d59ef0 100644 (file)
@@ -38,10 +38,6 @@ libsamlinclude_HEADERS = \
 
 samlbindinclude_HEADERS = \
        binding/ArtifactMap.h \
-       binding/GenericRequest.h \
-       binding/GenericResponse.h \
-       binding/HTTPRequest.h \
-       binding/HTTPResponse.h \
        binding/MessageDecoder.h \
        binding/MessageEncoder.h \
        binding/SAMLArtifact.h \
@@ -175,4 +171,7 @@ libsaml_la_LDFLAGS = -version-info 2:0:0
 install-exec-hook:
        for la in $(lib_LTLIBRARIES) ; do rm -f $(DESTDIR)$(libdir)/$$la ; done
 
-EXTRA_DIST = saml.vcproj
+EXTRA_DIST = saml.vcproj zlib
+
+dist-hook:
+       rm -rf `find $(distdir)/zlib -name .svn`