Major revamp of credential and trust handling code, PKIX engine still needs work.
[shibboleth/cpp-opensaml.git] / saml / Makefile.am
index 9a7a5da..b0f0d75 100644 (file)
@@ -47,8 +47,7 @@ samlbindinclude_HEADERS = \
        binding/SAMLArtifact.h \
        binding/SecurityPolicy.h \
        binding/SecurityPolicyRule.h \
-       binding/SOAPClient.h \
-       binding/URLEncoder.h
+       binding/SOAPClient.h
 
 encinclude_HEADERS = \
        encryption/EncryptedKeyResolver.h
@@ -73,7 +72,8 @@ saml1bindinclude_HEADERS = \
        saml1/binding/SAML1SOAPClient.h
 
 saml1profinclude_HEADERS = \
-       saml1/profile/AssertionValidator.h
+       saml1/profile/AssertionValidator.h \
+       saml1/profile/BrowserSSOProfileValidator.h
 
 saml2coreinclude_HEADERS = \
        saml2/core/Assertions.h \
@@ -90,13 +90,14 @@ saml2mdinclude_HEADERS = \
        saml2/metadata/ChainingMetadataProvider.h \
        saml2/metadata/EndpointManager.h \
        saml2/metadata/Metadata.h \
+       saml2/metadata/MetadataCredentialCriteria.h \
        saml2/metadata/MetadataFilter.h \
-       saml2/metadata/MetadataKeyInfoIterator.h \
        saml2/metadata/MetadataProvider.h \
        saml2/metadata/ObservableMetadataProvider.h
 
 saml2profinclude_HEADERS = \
-       saml2/profile/AssertionValidator.h
+       saml2/profile/AssertionValidator.h \
+       saml2/profile/BrowserSSOProfileValidator.h
 
 noinst_HEADERS = \
        internal.h
@@ -113,7 +114,6 @@ libsaml_la_SOURCES = \
        binding/impl/SecurityPolicy.cpp \
        binding/impl/SimpleSigningRule.cpp \
        binding/impl/SOAPClient.cpp \
-       binding/impl/URLEncoder.cpp \
        binding/impl/XMLSigningRule.cpp \
        saml1/core/impl/AssertionsImpl.cpp \
        saml1/core/impl/AssertionsSchemaValidators.cpp \
@@ -130,6 +130,7 @@ libsaml_la_SOURCES = \
        saml1/binding/impl/SAML1SOAPClient.cpp \
        saml1/binding/impl/SAML1MessageRule.cpp \
        saml1/profile/AssertionValidator.cpp \
+       saml1/profile/BrowserSSOProfileValidator.cpp \
        saml2/core/impl/Assertions20Impl.cpp \
        saml2/core/impl/Assertions20SchemaValidators.cpp \
        saml2/core/impl/Protocols20Impl.cpp \
@@ -158,6 +159,7 @@ libsaml_la_SOURCES = \
        saml2/binding/impl/SAML2SOAPClient.cpp \
        saml2/binding/impl/SAML2MessageRule.cpp \
        saml2/profile/AssertionValidator.cpp \
+       saml2/profile/BrowserSSOProfileValidator.cpp \
        encryption/EncryptedKeyResolver.cpp \
        signature/ContentReference.cpp \
        signature/SignatureProfileValidator.cpp \