Stop building tests when disabled
[shibboleth/cpp-opensaml.git] / samltest / Makefile.am
index 0dc3ee6..0209c14 100644 (file)
@@ -105,9 +105,10 @@ noinst_HEADERS = \
 
 nodist_samltest_SOURCES = $(samltest_h:.h=.cpp)
 
+if BUILD_UNITTEST
 BUILT_SOURCES = $(nodist_samltest_SOURCES)
-
 CLEANFILES = $(nodist_samltest_SOURCES)
+endif
 
 do-cxxtestgen:
        if test "$(CPPFILE)" = "samltest.cpp"; then \