Update gitignore to account for subdirs / missing files.
[shibboleth/cpp-opensaml.git] / samltest / Makefile.am
index 0dc3ee6..124f4ce 100644 (file)
@@ -14,6 +14,7 @@ samltest_h = \
     SAMLArtifactType0002Test.h \
     SAMLArtifactType0004Test.h \
     ArtifactMapTest.h \
+    CookieTest.h \
     encryption/EncryptedAssertionTest.h \
     signature/SAML1AssertionTest.h \
     signature/SAML1RequestTest.h \
@@ -105,9 +106,10 @@ noinst_HEADERS = \
 
 nodist_samltest_SOURCES = $(samltest_h:.h=.cpp)
 
+if BUILD_UNITTEST
 BUILT_SOURCES = $(nodist_samltest_SOURCES)
-
 CLEANFILES = $(nodist_samltest_SOURCES)
+endif
 
 do-cxxtestgen:
        if test "$(CPPFILE)" = "samltest.cpp"; then \