Update gitignore to account for subdirs / missing files.
[shibboleth/cpp-opensaml.git] / samltest / Makefile.am
index 106305c..124f4ce 100644 (file)
@@ -14,6 +14,7 @@ samltest_h = \
     SAMLArtifactType0002Test.h \
     SAMLArtifactType0004Test.h \
     ArtifactMapTest.h \
+    CookieTest.h \
     encryption/EncryptedAssertionTest.h \
     signature/SAML1AssertionTest.h \
     signature/SAML1RequestTest.h \
@@ -98,16 +99,20 @@ samltest_h = \
     saml2/profile/SAML2PolicyTest.h
 
 noinst_HEADERS = \
-       binding.h \
+    binding.h \
     internal.h \
-    signature/SAMLSignatureTestBase.h
+    signature/SAMLSignatureTestBase.h \
+    $(samltest_h)
 
 nodist_samltest_SOURCES = $(samltest_h:.h=.cpp)
 
+if BUILD_UNITTEST
+BUILT_SOURCES = $(nodist_samltest_SOURCES)
 CLEANFILES = $(nodist_samltest_SOURCES)
+endif
 
 do-cxxtestgen:
-       if test $(HFILE) = "samltest.h"; then \
+       if test "$(CPPFILE)" = "samltest.cpp"; then \
                $(CXXTEST) --error-printer --have-eh --have-std --abort-on-fail -o $(CPPFILE) $(HFILE); \
        else \
                $(CXXTEST) --part --have-eh --have-std --abort-on-fail -o $(CPPFILE) $(HFILE); \
@@ -118,4 +123,4 @@ $(nodist_samltest_SOURCES): %.cpp: %.h
 
 samltest_LDADD = $(top_builddir)/saml/libsaml.la
 
-EXTRA_DIST = samltest.vcproj samltest.vcproj.filters $(samltest_h) data
+EXTRA_DIST = samltest.vcxproj samltest.vcxproj.filters data