Add subdir option to automake
[shibboleth/cpp-opensaml.git] / samltest / Makefile.am
index 0dc3ee6..674d6f1 100644 (file)
@@ -1,4 +1,4 @@
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign subdir-objects
 
 if BUILD_UNITTEST
 bin_PROGRAMS = samltest
@@ -14,6 +14,7 @@ samltest_h = \
     SAMLArtifactType0002Test.h \
     SAMLArtifactType0004Test.h \
     ArtifactMapTest.h \
+    CookieTest.h \
     encryption/EncryptedAssertionTest.h \
     signature/SAML1AssertionTest.h \
     signature/SAML1RequestTest.h \
@@ -105,9 +106,10 @@ noinst_HEADERS = \
 
 nodist_samltest_SOURCES = $(samltest_h:.h=.cpp)
 
+if BUILD_UNITTEST
 BUILT_SOURCES = $(nodist_samltest_SOURCES)
-
 CLEANFILES = $(nodist_samltest_SOURCES)
+endif
 
 do-cxxtestgen:
        if test "$(CPPFILE)" = "samltest.cpp"; then \