1.x Artifact decoder, unit test.
[shibboleth/cpp-opensaml.git] / samltest / Makefile.am
index 0c83dbe..965f91d 100644 (file)
@@ -13,10 +13,14 @@ samltest_h = \
     SAMLArtifactType0001Test.h \
     SAMLArtifactType0002Test.h \
     SAMLArtifactType0004Test.h \
+    ArtifactMapTest.h \
     signature/SAML1AssertionTest.h \
     signature/SAML1RequestTest.h \
     signature/SAML1ResponseTest.h \
     signature/SAML2AssertionTest.h \
+    security/AbstractPKIXTrustEngineTest.h \
+    security/ExplicitKeyTrustEngineTest.h \
+    saml1/binding/impl/SAML1POSTTest.h \
     saml1/core/impl/ActionTest.h \
     saml1/core/impl/AdviceTest.h \
     saml1/core/impl/AssertionIDReferenceTest.h \
@@ -27,12 +31,14 @@ samltest_h = \
     saml1/core/impl/AudienceRestrictionConditionTest.h \
     saml1/core/impl/AudienceTest.h \
     saml1/core/impl/AuthenticationStatementTest.h \
+    saml2/binding/impl/SAML2POSTTest.h \
     saml2/core/impl/Action20Test.h \
     saml2/core/impl/Advice20Test.h \
     saml2/core/impl/Artifact20Test.h \
     saml2/core/impl/ArtifactResolve20Test.h \
     saml2/core/impl/ArtifactResponse20Test.h \
     saml2/core/impl/Assertion20Test.h \
+    saml2/core/impl/AssertionIDRef20Test.h \
     saml2/core/impl/AssertionIDRequest20Test.h \
     saml2/core/impl/AssertionURIRef20Test.h \
     saml2/core/impl/Attribute20Test.h \
@@ -78,7 +84,6 @@ samltest_h = \
     saml2/core/impl/StatusCode20Test.h \
     saml2/core/impl/StatusDetail20Test.h \
     saml2/core/impl/StatusMessage20Test.h \
-    saml2/core/impl/StatusResponse20Test.h\
     saml2/core/impl/Subject20Test.h\
     saml2/core/impl/SubjectConfirmation20Test.h\
     saml2/core/impl/SubjectConfirmationData20Test.h\
@@ -87,6 +92,7 @@ samltest_h = \
     saml2/metadata/FilesystemMetadataProviderTest.h
 
 noinst_HEADERS = \
+       binding.h \
     internal.h \
     signature/SAMLSignatureTestBase.h