Clean up doc/schema makefiles.
[shibboleth/cpp-opensaml.git] / schemas / Makefile.am
index 7d7b583..fb7593d 100644 (file)
@@ -3,9 +3,7 @@ AUTOMAKE_OPTIONS = foreign
 \r
 pkgxmldir = $(datadir)/xml/@PACKAGE@\r
 \r
-pkgxml_DATA = saml20-catalog.xml \\r
-       saml10-catalog.xml \\r
-       saml11-catalog.xml \\r
+schemafiles = \r
        cs-sstc-schema-assertion-01.xsd \\r
        cs-sstc-schema-protocol-01.xsd \\r
        cs-sstc-schema-assertion-1.1.xsd \\r
@@ -47,6 +45,12 @@ pkgxml_DATA = saml20-catalog.xml \
        sstc-saml-metadata-ext-query.xsd \\r
        sstc-saml-protocol-ext-thirdparty.xsd\r
 \r
+pkgxml_DATA = \\r
+       saml20-catalog.xml \\r
+       saml10-catalog.xml \\r
+       saml11-catalog.xml \\r
+       $(schemafiles)\r
+\r
 #\r
 # Some of these need building\r
 #\r
@@ -66,11 +70,13 @@ saml10-catalog.xml: ${srcdir}/saml10-catalog.xml.in Makefile ${top_builddir}/con
 saml11-catalog.xml: ${srcdir}/saml11-catalog.xml.in Makefile ${top_builddir}/config.status\r
        $(MAKE) do-build-file FILE=$@\r
 \r
-CLEANFILES = saml20-catalog.xml \\r
+CLEANFILES = \\r
+       saml20-catalog.xml \\r
        saml10-catalog.xml \\r
        saml11-catalog.xml\r
 \r
 EXTRA_DIST = \\r
        saml20-catalog.xml.in \\r
        saml10-catalog.xml.in \\r
-       saml11-catalog.xml.in\r
+       saml11-catalog.xml.in \\r
+       $(schemafiles)\r