Use shibboleth-sp as package name for compatibility.
[shibboleth/cpp-sp.git] / doc / Makefile.am
index 03f93ee..36ba021 100644 (file)
@@ -1,10 +1,12 @@
 AUTOMAKE_OPTIONS = foreign
 
-pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
+pkgdocdir = $(datadir)/doc/@PACKAGE_NAME@-@PACKAGE_VERSION@
+pkgwebdir = $(datadir)/@PACKAGE_NAME@
 
 install-data-hook:
-       cp -r api $(DESTDIR)$(pkgdocdir)
-       rm -rf `find $(DESTDIR)$(pkgdocdir)/api -name .svn`
+       if test -d api ; then \
+               cp -r api $(DESTDIR)$(pkgdocdir); \
+       fi;
 
 docfiles = \
        CREDITS.txt \
@@ -14,10 +16,12 @@ docfiles = \
        RELEASE.txt \
        FASTCGI.LICENSE \
        OPENSSL.LICENSE \
-       LOG4CPP.LICENSE \
-       main.css \
-       logo.jpg
-       
+       LOG4CPP.LICENSE
+
+webfiles = main.css
+
 pkgdoc_DATA = $(docfiles)
 
-EXTRA_DIST = $(docfiles) api
+pkgweb_DATA = $(webfiles)
+
+EXTRA_DIST = $(docfiles) $(webfiles)