Remove api directory from dist.
[shibboleth/cpp-sp.git] / doc / Makefile.am
index 3a0692b..36ba021 100644 (file)
@@ -1,11 +1,11 @@
 AUTOMAKE_OPTIONS = foreign
 
-pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
+pkgdocdir = $(datadir)/doc/@PACKAGE_NAME@-@PACKAGE_VERSION@
+pkgwebdir = $(datadir)/@PACKAGE_NAME@
 
 install-data-hook:
        if test -d api ; then \
                cp -r api $(DESTDIR)$(pkgdocdir); \
-               rm -rf `find $(DESTDIR)$(pkgdocdir)/api -name .svn`; \
        fi;
 
 docfiles = \
@@ -16,10 +16,12 @@ docfiles = \
        RELEASE.txt \
        FASTCGI.LICENSE \
        OPENSSL.LICENSE \
-       LOG4CPP.LICENSE \
-       main.css \
-       logo.jpg
-       
+       LOG4CPP.LICENSE
+
+webfiles = main.css
+
 pkgdoc_DATA = $(docfiles)
 
-EXTRA_DIST = $(docfiles) api
+pkgweb_DATA = $(webfiles)
+
+EXTRA_DIST = $(docfiles) $(webfiles)